PHP 5.6 для Denwer

PHP 5.6 для Denwer

1280 853 admin

Каждый, кто занимается созданием сайтов, в один прекрасный день сталкивается с проблемой, когда какой-нибудь скрипт или CMS (например, Opencart 2.3) не хочет работать, потому что им требуется версия PHP выше установленной в системе. Может так же появиться ошибка «php5.4+ required». И если у нормального хостера эта проблема решается просто изменением версии в настройках сайта, то в Denwer это не работает.

Для обновления до версии 5.6 нужно сделать следующее:

  1. Скачать архив php5.6_for_denwer.zip
  2. Остановить Denwer с помощью ярлыка Stop Denwer
  3. Перейти по пути Z:\usr\local и удалить папки php5 и apache
  4. Распаковать архив по тому же пути
  5. Запустить Denwer
  6. Вы восхитительны!
59 комментариев
  • Владислав 30.06.2017 в 03:59

    спасиб

  • Работает

  • спс

  • Алексей 11.08.2017 в 15:44

    Спасибо!

  • Андрей 25.08.2017 в 21:35

    спасибо, все работает!!!

  • Виктор 05.09.2017 в 08:18

    Ничего не работает, пишет запуск программы невозможен из-за отсутствия MSVCR110.dll

  • спасибо! работает наконец-то))

  • Спасибо ты очень помог!Всё прошло Быстро и понятно,С одного раза!Автору бабла побольше ))

  • Анатолий 17.10.2017 в 11:21

    Спасибо! Все ок. Коротко ясно и поделу

  • Спасибо, сразу же все заработало!!!

  • Вячеслав 22.10.2017 в 01:43

    Всё гут! Спасибо!

  • Ребяты, а у меня после этого на макете (html5+CSS win1251) вместо букАв одни кракозябры

    • попробуйте прописать в заголовке
      header(«Content-Type: text/html; charset=windows-1251»);

  • Дык оно там есть и на старом денвере работало нормуль…

  • сергей 19.11.2017 в 11:44

    у меня не запускается апачи

  • Всё просто, без воды и прочего. От души)

  • Такая вот штука выскочила:

    %1 не является приложением Win32
    Command file:
    «httpd.exe -w»
    working directory
    «.»

  • Сначала ругается, что не является приложением Win 32, а потом то, что написано выше

    • затрудняюсь вам что-то посоветовать, т.к. мало информации. архив точно работает с последней версией денвера на оф. сайте. либо вы где-то ошиблись в инструкции, либо у вас несовместимая система (проверял на win 10)

      • Win XP x 32
        Так-то все работает, сбой при обновлении. После обновления жумлы до 3.8.3 появляется ошибка с рекомендацией:
        ошибка

        Мы обнаружили, что ваш сервер использует PHP 5.3.13, который устарел и больше не получает официальные обновления безопасности его разработчиками. Joomla! Проект рекомендует обновить ваш сайт до PHP 5.6 или более поздней версии, который будет получать обновления безопасности по крайней мере до 2018-12-31. Попросите своего хоста сделать PHP 5.
        6 или более поздней версии по умолчанию для вашего сайта. Если ваш хост уже готов к работе с PHP 5.6, включите PHP 5.6 в корневом каталоге и в «администраторе» вашего сайта — обычно вы можете сделать это самостоятельно с помощью инструмента на панели управления хостингом, но лучше спросить своего хоста, если вы не уверены.

  • При попытке вручную запустить php.exe ругается, нет доступа. При возврате к старой версии, все работает, но проблема в том, что жумла 3.8.3 просит PHP не ниже версии 5.6

    • можно сделать ход конем — скачать open server, тоже хороший инструмент. на денвере свет клином не сошелся

  • Здравствуйте, Сергей !
    Все работает, но возникает проблема с кодировкой страниц.
    Например тестовые страницы открываются в «ромбиках» вместо букв….

  • Дмитрий 24.01.2018 в 17:44

    Обновил, работает. Но если в .htaccess стоит директива <Files то выдает 500 ошибку.И текст ошибки кракозяблами. Так что прочитать ошибку не возможно. Подскажите, как исправить?

  • спасибо.спасибо,спасибо! Огромная благодарность!!! Вы восхитительны!

  • Богдан 17.02.2018 в 08:34

    А как под эту комбинацию установить Ioncube Loade ? Все делал по инструкции как для Php 5.3 ничего не инсталировалось, может быть кто в курсе?

  • Попробую сейчас

  • Руслан 27.02.2018 в 21:55

    Замечательно! Единственный способ который сработал.

  • Реально сработал. Спасибо!

  • Андрей 19.03.2018 в 15:43

    СПАСИБО Большое….Человечище !!!!!

  • Максим 22.03.2018 в 10:57

    Благодарю

  • Человек, ты МЕГО-КРУТ. Спасибище огромное

  • Татьяна 23.04.2018 в 19:35

    БОЛЬШОЕ СПАСИБО! ЦЕЛЫЙ ДЕНЬ МУЧАЛАСЬ, А ТУТ СДЕЛАЛА И СРАЗУ ЗАРАБОТАЛО.УРА!!!

  • cialis great britain 28.04.2018 в 02:37

    Many thanks! Ample info.

  • Спасибо огромное. Но всюду пишу что только надо папку PHP5 заменить, а у Вас плюс еще и apache, почему так?

  • Станислав 02.05.2018 в 15:43

    Все получилось! Спасибо!!!

  • Спасибо!!!

  • Андрей 04.05.2018 в 09:42

    Огромное спасибо за Ваши труды!!!!

  • Единственный сайт, который помог)). Админу добра

  • Евгений 09.05.2018 в 23:54

    Человек! Человечище! Я так долго с роликами париллся, что бы обновиться, а тут раз и всё готово!

  • Спасибо
    Автор молодец 1-2-3 и все, замучился ютуб лопатить

  • Дорогие друзья скоро осталось до престоящего отпуска в связи с этим вопрос кто куда подумывает поехать отдыхать?
    Подумываем с друзьями поехать отдыхать, кто где ищет жилье в геленджике?
    Боюсь что обманут сейчас столько мошенников страшно бронировать.

  • Алексей 23.05.2018 в 11:42

    Спасибо! PHP 5.6 для Denwer cтал сразу, без ошибок.

  • Азамат 29.05.2018 в 04:47

    Спасибо! Очень помог, Гелика тебе)

  • Ахрорхон 29.05.2018 в 06:33

    Большое спасибо!!
    Коротко и ясно

  • Original work
    http://premium.dating.pornpost.in/?post.angelique
    woman seeks man melbourne have sex with women rich cougars dating all free dating sites in usa bi singles

  • Самый лучший ответ на вопрос «Как обноить PHP 5.6 для Denwer»!!! Без косяков и костылей работает за считанные секунды — браво!

  • Алексей 15.06.2018 в 23:47

    Спасибо, дружище! Помогло! )

  • Добрый день! При попытке перехода в phpmyadmin пишет Расширение mysqli не найдено. Пожалуйста, проверьте ваши настройки PHP… Строка в PATH имеет вид C:\Server\web\mysql\bin; C:\Server\web\php;

    Подскажите, пожалуйста, что делать?

Comments are closed.